Information: Forum is in read-only mode
For details and other support options see

buffer overflow in rsyslog with centos7

This is the place for developers to discuss bugs, new features and everything else about code changes.

Moderator: alorbach

Google Ads

buffer overflow in rsyslog with centos7

Postby uxio » Tue Feb 20, 2018 4:33 pm

Hello currently i'm using centos6 ( rsyslog7-7.4.10-3) with no problems on production environment.

i have an infraestructure of 300 servers login to rsyslog by udp and tcp.
rsyslog parse logs and write them to disk and send to a elasticsearch cluster.

commonly has about 2000 open file descriptors and about 3200 msg per second.

i want to upgrade to centos7 but with quite same configuration ( disabling imjournal )
every 30s rsyslog hangs.

this is the error:

*** buffer overflow detected ***: rsyslogd terminated
======= Backtrace: =========
======= Memory map: ========

i tried centos7 rsyslog-7.4.7-16, rsyslog-8.24.0-12
and tried last version from rsyslog page: rsyslog-8.33.0-1

all of them hangs with same message.

i tryed to upgrade user limits of file descriptors and threads.
i can't figure out witch buffer is overflowed.

i suppose that is problem of centos7 environment but i don't know what.

could someone help me?
Posts: 1
Joined: Tue Feb 20, 2018 3:56 pm

Urgent Question?

  • Pulling out your Hair?
  • Wasting Time and Money?
  • Deadline Approaching?

Google Ads

Return to Developer's Corner

Who is online

Users browsing this forum: No registered users and 0 guests