rsyslog / LogAnalyzer / MySQL / SLES12

Everything related with getting rsyslog up and running (but not beyond that point ;))

Moderator: rgerhards

Google Ads


rsyslog / LogAnalyzer / MySQL / SLES12

Postby tbrinkmann » Fri Dec 12, 2014 12:50 pm

Hello,

we are trying to use LogAnalyzer with rsyslog and mysql.

Systemconfig: SLES12
rsyslog-module-mysql-8.4.0-5.1.x86_64
rsyslog-8.4.0-5.1.x86_64
MySQL-server-5.6.22-1.linux_glibc2.5.x86_64
apache2-prefork-2.4.10-6.1.x86_64
apache2-mod_php5-5.5.14-7.1.x86_64
LogAnalyzer Version 3.6.6 (stable), 2014-09-02

After successful configure the LogAnalyzer with web formula. We create the rsyslog tables in the loganalyzer schema.

mysql> show tables
-> ;
+------------------------+
| Tables_in_syslog |
+------------------------+
| SystemEvents |
| SystemEventsProperties |
| logcon_charts |
| logcon_config |
| logcon_dbmappings |
| logcon_fields |
| logcon_groupmembers |
| logcon_groups |
| logcon_savedreports |
| logcon_searches |
| logcon_sources |
| logcon_users |
| logcon_views |
+------------------------+
13 rows in set (0.00 sec)

Syslog is writhing to the SystemEvents tables

mysql> select count(*) from SystemEvents;
+----------+
| count(*) |
+----------+
| 33 |
+----------+
1 row in set (0.00 sec)

but in the LogAnalyzer we cannot see any events.
---> Could not find the configured table, maybe misspelled or the tablenames are case sensitive

Also we are getting the php errors

Warning: ob_start(): function 'ob_gzhandler' not found or invalid function name in /srv/www/htdocs/syslog/include/functions_common.php on line 647
Notice: ob_start(): failed to create buffer in /srv/www/htdocs/syslog/include/functions_common.php on line 647

Can anyone help to understand where to find a solution ?

Thanks a lot !
tbrinkmann
tbrinkmann
New
 
Posts: 4
Joined: Fri Dec 12, 2014 12:41 pm

Urgent Question?

  • Pulling out your Hair?
  • Wasting Time and Money?
  • Deadline Approaching?

Re: rsyslog / LogAnalyzer / MySQL / SLES12

Postby tbrinkmann » Fri Dec 12, 2014 2:30 pm

Re,

I installed the zlib extension into php5 and reconfigured the database source and now it works.

Thanks
tbrinkmann
New
 
Posts: 4
Joined: Fri Dec 12, 2014 12:41 pm

Google Ads



Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron