Information: Forum is in read-only mode
For details and other support options see

Reading from logfile

You need additional help with phplogcon, then write into this forum.

Moderator: alorbach

Google Ads

Reading from logfile

Postby mico85 » Tue Apr 09, 2013 11:37 am

Hi to all,

I am new to loganalyzer. I installed it two days ago in order to monitor logs form specific network devices(CISCO rt and sw). SInce i am going open-source i am using a simple tool as a syslog server , it is called tftpd32. I configured devices to send logs to this server. The file format this server saves logs is attached. Then i configure loganalyzer to read logs form DiskFile and i put as a source the above file. The problem is the logs are not displayed with the correct fields(screenshot attached). I tried to change view setting but nothing. Can you tell me what i am doing wrong or is there a line i should modify or add into the config.php or logstream classes.

Thnx in advance
(391 Bytes) Downloaded 221 times
loganalyzer_fields_error.png (59.92 KiB) Viewed 17378 times
Posts: 1
Joined: Tue Apr 09, 2013 11:16 am

Urgent Question?

  • Pulling out your Hair?
  • Wasting Time and Money?
  • Deadline Approaching?

Re: Reading from logfile

Postby alorbach » Fri Apr 12, 2013 9:06 am

I reviewed the sample logfile you attached.
This is not a common syslog format, so you will need to write your own custom message line parser to resolve it fields. But it looks pretty simply, I think you can use one of the existing message line parsers, and create your own out of it.

best regards,
Andre Lorbach
Site Admin
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Reading from logfile

Postby tomasm » Wed Apr 24, 2013 11:14 am

HI mico85,
I have the same problem with CISCO rt and sw plus other problem with syslog. And I have question on you. How did you create syslog.log (attachment) .
Im geting messages as
<187>176: Apr 17 07:00:39: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to down

but without ip address or hostname. But you have different messges
Tue Apr 09 12:05:17 2013: <187>85: ip-of-the-device: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
I looging for solution how I get messages as you have. Is it setup of syslog or cisco.

Thank you Tomas
Posts: 1
Joined: Wed Apr 24, 2013 10:56 am

Google Ads

Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests