Activating UserDB failed

Everything which is related to the installation of phpLogCon.

Google Ads


Activating UserDB failed

Postby danielandross » Wed Oct 31, 2012 1:09 pm

Hello,

on my LogServer running LogAnalyzer with postgres I attempted to activate userdb.
I installed mysql on localhost, created user mysql and set the password.

Then I followed this Guide http://wiki.rsyslog.com/index.php/How_t ... stallation to activate the userdb.
It did not show the wizard but only the text 'Hacking attempt'. From that moment on the LogAnalyzer is broken and will show a blank page, only.

How do I activate the userdb properly?

regards
Daniel
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Urgent Question?

  • Pulling out your Hair?
  • Wasting Time and Money?
  • Deadline Approaching?

Re: Activating UserDB failed

Postby alorbach » Wed Oct 31, 2012 2:39 pm

Which version of Loganalyzer are you using? Have you added the "UserDBConvertAllowed" setting in your config.php as described?
What is the full output of convert.php?
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Activating UserDB failed

Postby danielandross » Mon Nov 05, 2012 9:29 am

Hello,

I am using loganalyzer-3.5.2
Yes, UserDBConvertAllowed was added.
The execution of configure.sh will produce no stdout, at all. After that there will be no LogAnalyzer page.

These are the total options:
$CFG['UserDBEnabled'] = true;
$CFG['UserDBServer'] = 'localhost';
$CFG['UserDBPort'] = 3306;
$CFG['UserDBName'] = 'loganalyzer';
$CFG['UserDBPref'] = 'logcon_';
$CFG['UserDBUser'] = 'mysql';
$CFG['UserDBPass'] = 'mysqlpw;
$CFG['UserDBLoginRequired'] = true;
$CFG['UserDBAuthMode'] = 0;
$CFG['UserDBConvertAllowed'] = true;
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Re: Activating UserDB failed

Postby alorbach » Mon Nov 05, 2012 10:43 am

configure.sh? I asked for output of "convert.php" ;). I guess there is a misunderstanding here. As Loganalyzer is a php application, all things are done within the application itself, so you need to use your webbrowser and open convert.php within your Loganalyzer installation to start the conversion.

best regards,
Andre Lorbach
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Activating UserDB failed

Postby danielandross » Mon Nov 05, 2012 12:20 pm

Hello Andre,

when I request LogAnalyzer/convert.php in my browser I get an blank page. Same as in index.php
Both happens as soon as I set
$CFG['UserDBEnabled'] = true;
When I set it to false and restart apache I may call LogAnalyzer again.

thanks for support.

regards Daniel
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Re: Activating UserDB failed

Postby alorbach » Mon Nov 05, 2012 1:47 pm

If you get a blank page, there properly is a internal server error, take a look to the apache error logfile located in /var/log/apache.
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Activating UserDB failed

Postby danielandross » Tue Nov 06, 2012 9:28 am

I don't see any severe errors here:

[Tue Nov 06 09:02:47 2012] [error] [client 10.15.212.133] File does not exist: /srv/www/htdocs/favicon.ico
[Tue Nov 06 09:02:47 2012] [error] [client 10.15.212.133] File does not exist: /srv/www/htdocs/favicon.ico
[Tue Nov 06 09:04:18 2012] [notice] caught SIGTERM, shutting down
[Tue Nov 06 09:04:18 2012] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Nov 06 09:04:18 2012] [notice] Apache/2.2.10 (Linux/SUSE) mod_ssl/2.2.10 OpenSSL/0.9.8h PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Re: Activating UserDB failed

Postby alorbach » Tue Nov 06, 2012 9:51 am

Have you checked for other error logfiles?
Can you please attach your config.php to this post? I want to check for possible syntax error's. I have no other explanation for a blank page on convert.php right now.

regards,
Andre
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Activating UserDB failed

Postby danielandross » Tue Nov 06, 2012 10:38 am

Hello,

the other apache logs don't show errors either. Plus the blank page happens not only on convert.php but the normal index.php als well, once I set UserDBEnabled to true.

I attached the config.

thanks.
Attachments
config.7z
Die Config.PHP
(3.69 KiB) Downloaded 290 times
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Re: Activating UserDB failed

Postby alorbach » Tue Nov 06, 2012 11:09 am

Your configuration file is fine.
Can you check if php mysql extension are installed? This could explain the blank pages, still you should see detailed error's in Apache logfiles somewhere.

regards,
Andre
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Activating UserDB failed

Postby danielandross » Tue Nov 06, 2012 1:25 pm

OK, php5-mysql was not installed.
Now I get an error page instead of a blank one:

Database error: Cannot use database 'loganalyzer'
mysql error: Access denied for user 'mysql'@'localhost' to database 'loganalyzer'
mysql error number: 1044
Date: 06.11.2012 @ 13:22
Script: /LogAnalyzer/convert.php
Referer:

Guess i will have to check the database i created again. Thank you for the help.
danielandross
Avarage
 
Posts: 14
Joined: Mon Apr 30, 2012 2:20 pm

Google Ads



Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron