Problem with PDF Reports

You need additional help with phplogcon, then write into this forum.

Google Ads


Problem with PDF Reports

Postby MHI » Thu Sep 13, 2012 1:10 am

I encounter problems when creating PDF reports of eventlog summaries for example. On a couple of pages of a reports the Description and EventID is just cut of the right border of the page, while other pages look okay. It also happens though that on one page the events are over the border some are not. This is happening when there is another host where the report layout is okay, so it's really on host basis. On one host all events are displayed correctly, while on another one, all are displayed incorrectly. I have checked the db if I have blanks or characters in it that may affect the output, but all looks okay. Could it be a problem of the html2fpdf generator. From what I understood is that the html output is always created first and then converted into a pdf. I will also take a look into the html output, to see if I can identify some different behavior of the hosts working and non working. Is there any chance after creating an html output to manually start the pdf conversion on that creating html report via command line. It would be then easier to just manipulate the html code directly in order to see the changes. Or does anybody have an idea, why those reports are "corrupted" ?

By the way I am using V3.5.5
Michael
MHI
New
 
Posts: 3
Joined: Thu Sep 13, 2012 12:59 am

Urgent Question?

  • Pulling out your Hair?
  • Wasting Time and Money?
  • Deadline Approaching?

Re: Problem with PDF Reports

Postby alorbach » Thu Sep 13, 2012 3:18 pm

Hi,

yes your understanding is correct. For PDF Format, a very basic HTML Report is generated (different html templates) and converted into PDF using html2pdf script. There might be flaws. You could either hook into the "classes/report.class.php" to see what the generated HTML Looks like, or take a look to the report templates like "classes/report.syslog.syslogsummary/report.syslog.syslogsummary.template.pdf" which is basically the template HTML code.

best regards,
Andre Lorbach
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Problem with PDF Reports

Postby MHI » Fri Sep 14, 2012 4:38 pm

I finally found the error and what is causing this strange behaviour. There are several log entries in my DB from MS Servers that look like:

Logon attempt by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0 Logon account: Administrator Source Workstation: ABCDEFGH Error Code: 0xC000006A

When I take out the "MICROSOFT_AUTHENTICATION_PACKAGE_V1_0" part, the whole reports are working correctly.
I am not sure, if this is the only windows event message that causes these problems.

I also just double checked my syslog reports and the same error occurs. I just haven't analyzed yet, what casuses those reports to become "corrupted"

Just as a remark. The reports generated in V3.2.3 are working correctly, without removing the event mentioned above.

For all the events being writen to the db I am using rsyslog 3.22 and the Windows machines are reporting via Snare agent 4.0.12.

Michael
MHI
New
 
Posts: 3
Joined: Thu Sep 13, 2012 12:59 am

Re: Problem with PDF Reports

Postby alorbach » Fri Sep 14, 2012 4:52 pm

It's properly a linebreak issue, as MICROSOFT_AUTHENTICATION_PACKAGE_V1_0 can not be breaked as once.
You may try to lower the font sizes in the pdf (html) templates, this may solve the problem.

best regards,
Andre
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Problem with PDF Reports

Postby MHI » Thu Sep 20, 2012 1:35 pm

I guess I have found the problem. It's as you mentioned in the pdf(html) template in your statement {msg:wordwrap:32} if you change that to {msg:wordwrap:15}. Everything works corectly and the wordbrakes are functioning as expected on all reports I have run. Maybe you shoul dchange that in your code, as I haven't found a reason to set this to 32, but probably you have a good one :D

Thanks again for your help
Michael
MHI
New
 
Posts: 3
Joined: Thu Sep 13, 2012 12:59 am

Google Ads



Return to Help

Who is online

Users browsing this forum: No registered users and 0 guests

cron