Information: Forum is in read-only mode
For details and other support options see https://www.adiscon.com/news/support-forum-set-to-read-only-mode/

Error 1053 : The service did not respond to the start or

Discussions on Microsoft's new server operating system. This works in conjunction with the http://www.windows-expert.net web pages.

Moderator: alorbach

Google Ads


Error 1053 : The service did not respond to the start or

Postby jake_t » Tue Jul 18, 2006 8:39 am

Hello
I have an application written in .Net 2.0 running on Windows Server 2003 std edition.
I am trying to turn this app into a service, however , when I try to start the service I have created , I receive the error :

" Error 1053 : The service did not respond to the start or control request in a timely fashion."

MS support says it was fixed on .Net 1 , but I am using the 2.0 framework.

As a test ,i also tried turning notepad.exe as service ,and got the same response.

Does anybody know this error on 2.0?

Thanks in advance
Jake
jake_t
New
 
Posts: 3
Joined: Tue Jul 18, 2006 8:36 am

Postby alorbach » Tue Jul 18, 2006 8:56 am

You can only run programs as service, which have been designed for this.
So notepad.exe and similar apps will not run as service.

I assume that you have designed your application to be run as service, with the needed service classes and so on. In this case, enabled "Allow service to interact with desktop" option in the properties of your service (Computer Management).

Then start the Service, and use the VS2005 Debugger to attach to your service process! Then you will be able to debug into your app, and see where it hangs.

best regards,
Andre Lorbach
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Postby jake_t » Tue Jul 18, 2006 12:20 pm

1) Thank you

2) What classes are needed to be added?

3) Is it just for 2003 & .Net that you have to add this classes?

I made a try with Xp and notepad and it worked fine.

Jake
jake_t
New
 
Posts: 3
Joined: Tue Jul 18, 2006 8:36 am

Postby alorbach » Tue Jul 18, 2006 12:31 pm

Take a look to the MSDN Documentation, this is the right entry point:
http://msdn2.microsoft.com/en-us/library/ms279988.aspx

Then check the following tutorial from CodeProject.com:
http://www.codeproject.com/Purgatory/Wi ... rvices.asp

It is for dotnet 1.1 but it should the in same way for 2.0!

regards,
Andre
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Postby jake_t » Thu Jul 20, 2006 7:27 am

Doesn't it have something to do with privileges?
jake_t
New
 
Posts: 3
Joined: Tue Jul 18, 2006 8:36 am

Postby alorbach » Fri Jul 21, 2006 3:15 pm

not really no.
Did you follow the article from codeproject? It worked for me ...
alorbach
Site Admin
 
Posts: 1627
Joined: Thu Feb 13, 2003 11:55 am

Re: Error 1053 : The service did not respond to the start or

Postby tino » Fri May 27, 2011 9:42 pm

Hello guys,
I have the same problem. In my case I'm trying to run a runasservice.exe program. I have two window 2003 servers, on the first one is woking ok, but on the other one I'm getting the same error. I have some difference on the security pacth installed on each server, I hope this is the reason. I'll let you know if I found something.

Cheers,
tino
New
 
Posts: 1
Joined: Fri May 27, 2011 9:38 pm

Google Ads



Return to Windows Server 2003

Who is online

Users browsing this forum: No registered users and 0 guests

cron