Information: Forum is in read-only mode
For details and other support options see https://www.adiscon.com/news/support-forum-set-to-read-only-mode/

ActiveX component can't create object

Support, Questions and Discussions on SimpleMail

Moderator: alorbach

Google Ads


ActiveX component can't create object

Postby psaban20 » Fri May 04, 2007 10:29 pm

I'm getting an error creating the object:

Set Mailer = Server.CreateObject("ADISCON.SimpleMail.1")

Running a new installation of
Windows 2003 Server R2
Standard x64 Edition
Service Pack 2

Adiscon SimpleMail Version 2.11

I ran install.bat successfully.

Any help or ideas would be greatly appreciated.

Thank you.
psaban20
New
 
Posts: 5
Joined: Fri May 04, 2007 10:22 pm

Postby psaban20 » Sat May 05, 2007 2:45 am

I have now uninstalled version 2.11 and have installed version 3.1 and am receiving the following error:

Server object error 'ASP 0177 : 800401f3'

Server.CreateObject Failed

I've read the previous posting in this forum regarding this error, but I don't believe it was resolved in that discussion.

Any help is appreciated.
psaban20
New
 
Posts: 5
Joined: Fri May 04, 2007 10:22 pm

Postby mmeckelein » Mon May 07, 2007 8:49 am

Please, could you try the following:
1. open a command prompt
2. navigate to SimpleMail folder
3. run the following command: regsvr32 -u simplemail.dll
in order to uninstall the simplemail component
4. run the follwoing command: regsvr32 simplemail.dll
in order to reinstall the component

Please report any error which occurs during these steps. If no error appears, please use the "SimpleMail Client" to test if simple mail works.

Best regards,
Michael Meckelein
Adiscon
mmeckelein
Adiscon Support
 
Posts: 176
Joined: Wed Mar 12, 2003 12:07 pm

Postby psaban20 » Mon May 07, 2007 5:30 pm

Unless I have downloaded the incorrect file the regsvr32, and simplemail.dll file do not exist in the simplemail folder. The contents of the folder created from the extracted zip is as follows:

file_id.diz
license.txt
manual.htm
readme.txt
setup.exe
simplemail.xml

I ran the setup.exe and I'm assuming that takes care of registering the simplemail.dll, but I still get the error previously mentioned.
psaban20
New
 
Posts: 5
Joined: Fri May 04, 2007 10:22 pm

Postby mmeckelein » Tue May 08, 2007 8:20 am

psaban20 wrote:Unless I have downloaded the incorrect file the regsvr32, and simplemail.dll file do not exist in the simplemail folder. The contents of the folder created from the extracted zip is as follows:

file_id.diz
license.txt
manual.htm
readme.txt
setup.exe
simplemail.xml

I ran the setup.exe and I'm assuming that takes care of registering the simplemail.dll, but I still get the error previously mentioned.


After running setup you should have the following files in your SimpleMail install directory:
Code: Select all
C:\Program Files\SimpleMail>dir
 Volume in drive C is System
 Volume Serial Number is ...

 Directory of C:\Program Files\SimpleMail

02/08/2007  01:38 PM    <DIR>          .
02/08/2007  01:38 PM    <DIR>          ..
06/14/2006  02:02 PM            85,353 manual.htm
06/14/2006  01:49 PM           114,688 SimpleMail.dll
05/16/2002  05:41 PM           270,336 SimpleMailClient.exe
               3 File(s)        470,377 bytes
               2 Dir(s)     923,512,832 bytes free

Did you try SimpleMailClient.exe to send an email?
mmeckelein
Adiscon Support
 
Posts: 176
Joined: Wed Mar 12, 2003 12:07 pm

Postby psaban20 » Tue May 08, 2007 4:49 pm

This is what i've done to this point.

I ran the setup.exe file which created the c:\program files (x86)\simplemail directory that contains the simplemail.dll file. At a command prompt while at the simplemail directory I executed regsvr32 simplemail.dll and was notified of its successful registration.

I did try to send an email using the client, but unsuccessfully. (If I click 'start test' after entering my smtp server, sender and recipient I receive the message SimpleMail Code Returned: -1)

I executed my asp page which sends emails and I now get the following error:

Microsoft VBScript runtime error '800a01ad'

ActiveX component can't create object

Thanks for you help,
Pablo
psaban20
New
 
Posts: 5
Joined: Fri May 04, 2007 10:22 pm

Postby mmeckelein » Wed May 09, 2007 9:31 am

psaban20 wrote:I did try to send an email using the client, but unsuccessfully. (If I click 'start test' after entering my smtp server, sender and recipient I receive the message SimpleMail Code Returned: -1)

-1 means that the mail server is not reachable. Please ensure that the mail server is reachable. Probably the easiest way is to use telnet:
Code: Select all
telnet yourmailserverip port



A colleague alerts me that the error given by the ASP page may be a 64bit issue. You have to enable 32bit support in your IIS to run simplemail successfully.

Configuring IIS to Run 32-bit Applications on 64-bit Windows (IIS 6.0):
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/405f5bb5-87a3-43d2-8138-54b75db73aa1.mspx?mfr=true
mmeckelein
Adiscon Support
 
Posts: 176
Joined: Wed Mar 12, 2003 12:07 pm

Postby psaban20 » Wed May 09, 2007 6:19 pm

Michael,

I have allowed 32 bit applications to run on my 64 bit system and I am now able to successfully execute my asp page. I still don't get the message actually sent but this is due to a failed communication to the smtp server as you have mentioned and I have confirmed by a failed attempt to telnet to port 25 on the server.

This seems to be a problem that I will have to troubleshoot on my own now that I know that the simplemail component is working.

Thanks for your help,
Pablo
psaban20
New
 
Posts: 5
Joined: Fri May 04, 2007 10:22 pm

Google Ads



Return to SimpleMail

Who is online

Users browsing this forum: No registered users and 0 guests

cron